Duolingo is experiencing increased errors
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 16:59 EDT
Investigating
We are currently investigating this incident.
Posted Apr 06, 2023 - 16:39 EDT
This incident affected: Duolingo.