Service Outage
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted Mar 20, 2019 - 13:05 UTC
Investigating
We are experiencing a service outage and are currently investigating the issue.
Posted Mar 20, 2019 - 12:50 UTC
This incident affected: Duolingo, Duolingo English Test, Duolingo for Schools, and Tinycards.