logged out splash page down
Incident Report for Duolingo
Resolved
The duolingo logged out home page was inaccessible for about 35 mins starting at 8.22pm EST.
Posted 11 months ago. May 02, 2018 - 00:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 11 months ago. May 02, 2018 - 00:46 UTC
This incident affected: Duolingo.