High Latency
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted Mar 08, 2019 - 20:35 UTC
Update
We are continuing to investigate this issue.
Posted Mar 08, 2019 - 19:59 UTC
Investigating
Duolingo is currently experiencing high latency. Engineers are working to identify the issue.
Posted Mar 08, 2019 - 19:58 UTC
This incident affected: Duolingo, Duolingo English Test, Duolingo for Schools, and Tinycards.