High Latency
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted about 1 year ago. Dec 18, 2017 - 21:29 UTC
Investigating
Duolingo is currently experiencing high latency
Posted about 1 year ago. Dec 18, 2017 - 20:57 UTC