High Latency
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted over 1 year ago. Jan 02, 2018 - 20:19 UTC
Investigating
Duolingo is currently experiencing high latency.
Posted over 1 year ago. Jan 02, 2018 - 20:05 UTC