High Latency
Incident Report for Duolingo
Resolved
The latency issue was identified and has been addressed. Services are now functioning normally.
Posted over 1 year ago. Jan 10, 2018 - 18:43 UTC
Investigating
Duolingo is currently experiencing high latency. Engineers are working to identify the issue.
Posted over 1 year ago. Jan 10, 2018 - 18:29 UTC