High Latency
Incident Report for Duolingo
Resolved
Latency issues have been resolved.
Posted over 1 year ago. Jan 09, 2018 - 20:42 UTC
Investigating
Duolingo is currently experiencing high latency.
Posted over 1 year ago. Jan 09, 2018 - 19:21 UTC