Some services unavailable
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted 11 months ago. May 04, 2018 - 15:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 11 months ago. May 04, 2018 - 14:35 UTC
This incident affected: Tinycards.