High Latency
Incident Report for Duolingo
Resolved
Duolingo service is operational.
Posted Mar 25, 2019 - 21:14 UTC
Monitoring
Engineers are monitoring the Duolingo service. Performance may still be slightly degraded.
Posted Mar 25, 2019 - 21:02 UTC
Update
Duolingo service is currently unavailable. Engineers are working to restore functionality.
Posted Mar 25, 2019 - 20:52 UTC
Identified
Duolingo is currently experiencing high latency. Engineers have identified the issue and are working to resolve it.
Posted Mar 25, 2019 - 20:17 UTC
This incident affected: Duolingo.