Duolingo is experiencing increased errors
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted Sep 08, 2023 - 11:34 EDT
Investigating
We are currently investigating this incident.
Posted Sep 08, 2023 - 11:03 EDT
This incident affected: Duolingo.