Duolingo is experiencing increased errors

Incident Report for Duolingo

Resolved

This incident has been resolved.
Posted Jun 08, 2023 - 17:38 EDT

Investigating

We are currently investigating this incident.
Posted Jun 08, 2023 - 16:47 EDT
This incident affected: Duolingo.