Tinycards outage
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted over 1 year ago. Feb 07, 2018 - 13:21 UTC
Investigating
Tinycards is currently experiencing an outage
Posted over 1 year ago. Feb 07, 2018 - 13:08 UTC