Schools database migration
Incident Report for Duolingo
Resolved
Maintenance period is done.
Posted 12 months ago. Jan 26, 2018 - 00:28 UTC
Investigating
We are experiencing scheduled maintenance to move the schools database. It is estimated to take approximately 60 minutes.
Posted 12 months ago. Jan 25, 2018 - 23:33 UTC