Duolingo is experiencing increased errors
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 18:39 EST
Investigating
We are currently investigating this incident.
Posted Nov 14, 2023 - 18:12 EST
This incident affected: Duolingo.