Duolingo is experiencing increased errors
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted Aug 10, 2022 - 23:21 EDT
Investigating
We are currently investigating this incident.
Posted Aug 10, 2022 - 23:13 EDT
This incident affected: Duolingo.