Duolingo is experiencing increased errors

Incident Report for Duolingo

Resolved

This incident has been resolved.
Posted Jul 19, 2023 - 12:40 EDT

Investigating

We are currently investigating this incident.
Posted Jul 19, 2023 - 12:05 EDT
This incident affected: Duolingo.