High Latency on Duolingo
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted May 23, 2019 - 18:19 UTC
Investigating
We are currently investigating this issue.
Posted May 23, 2019 - 15:18 UTC
This incident affected: Duolingo.