Duolingo is currently experiencing high latency.
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted over 1 year ago. Jan 05, 2018 - 17:51 UTC
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Jan 05, 2018 - 16:40 UTC