High Latency
Incident Report for Duolingo
Resolved
Duolingo is back to normal
Posted about 1 year ago. Dec 20, 2017 - 21:25 UTC
Investigating
Duolingo is currently experiencing high latency
Posted about 1 year ago. Dec 20, 2017 - 20:49 UTC