Android Lesson Start Failures
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted 11 months ago. Feb 27, 2018 - 03:14 UTC
Investigating
We are investigating an issue where some Android users are unable to start lessons or skill-specific practice.
Posted 11 months ago. Feb 27, 2018 - 02:20 UTC