High Latency
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted over 1 year ago. Dec 15, 2017 - 17:50 UTC
Update
Duolingo is currently experiencing a major outage
Posted over 1 year ago. Dec 15, 2017 - 17:12 UTC
Investigating
Duolingo is currently experiencing high latency
Posted over 1 year ago. Dec 15, 2017 - 17:04 UTC