Duolingo is experiencing increased errors
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted Jul 26, 2022 - 11:18 EDT
Investigating
We are currently investigating this incident.
Posted Jul 26, 2022 - 11:17 EDT
This incident affected: Duolingo.