Duolingo is experiencing increased errors
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 11:50 EDT
Update
We are continuing to investigate this issue.
Posted Sep 21, 2022 - 11:49 EDT
Investigating
We are currently investigating this incident.
Posted Sep 21, 2022 - 11:32 EDT
This incident affected: Duolingo.