Leaderboards Maintenance
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 02:22 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 28, 2022 - 23:53 EDT
Investigating
Leaderboards Under Maintenance: Your league page and statistics will temporarily be down as we complete maintenance and improvements. Any XP earned during this time will be saved, and will be added to your score by the time the maintenance is complete.
Posted Jun 28, 2022 - 23:53 EDT
This incident affected: Duolingo.