Tinycards High Latency
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted over 1 year ago. Jan 30, 2018 - 14:53 UTC
Investigating
Tinycards is currently experiencing high latency. Engineers are working to identify the issue.
Posted over 1 year ago. Jan 30, 2018 - 14:25 UTC