Duolingo Unavailable
Incident Report for Duolingo
Resolved
Duolingo services are available.
Posted Sep 25, 2019 - 21:06 UTC
Identified
The issue has been identified and a fix is being applied.
Posted Sep 25, 2019 - 20:43 UTC
This incident affected: Duolingo, Duolingo English Test, Duolingo for Schools, and Tinycards.