High Latency
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted May 07, 2019 - 22:35 UTC
Investigating
Duolingo is currently experiencing high latency. We are currently investigating the issue.
Posted May 07, 2019 - 20:02 UTC
This incident affected: Duolingo, Duolingo English Test, Duolingo for Schools, and Tinycards.