High Latency
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted Apr 03, 2019 - 19:32 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 03, 2019 - 19:08 UTC
Identified
Duolingo services are currently experiencing high latency. New sessions may be delayed.
Posted Apr 03, 2019 - 19:00 UTC
This incident affected: Duolingo, Duolingo English Test, Duolingo for Schools, and Tinycards.