High Latency
Incident Report for Duolingo
Resolved
This incident has been resolved.
Posted 12 months ago. Jun 22, 2018 - 19:20 UTC
Update
We are continuing to investigate this issue.
Posted 12 months ago. Jun 22, 2018 - 17:57 UTC
Investigating
Duolingo services are currently experiencing high latency
Posted 12 months ago. Jun 22, 2018 - 17:57 UTC
This incident affected: Duolingo, Duolingo English Test (DET), Duolingo for Schools, and Tinycards.